Kernel 2.4.21 woes

From: Madhusudan Singh (spammers-go-here_at_yahoo.com)
Date: 07/04/03


Date: Fri, 04 Jul 2003 09:40:49 -0400

Hi
        I had a perfectly running system (laptop) :

        1. RH 9.0
        2. Kernel 2.4.20 with the corresponding ACPI patch
        3. ALSA drivers 0.9.2

        I wanted to add a Netgear MA401 RA wireless card with hostap drivers
and
someone suggested that I upgrade to 2.4.21.

        Well, I did so, downloaded the ACPI patch for 2.4.21 and also ALSA
drivers
0.9.4 (decided to do a complete upgrade in a sense). Applied the patch,
compiled the kernel, etc.

        Now I have a serious problem :

        1. My NFS mounts (as a client) are excruciatingly slow - it takes 5
minutes
with lockd error =-5 errors.
        2. Owing to 1., I removed the mounting of my NFS volume. Now, my
GNOME startup flash screen waits around for about 5 minutes, then shows the
startup icons in quick succession, then a dark screen (has lasted five
minutes already as I write this). This entire process used to take about 20
seconds.

        Curious thing - the time events between 1 and 2 are "synchronized"
(used to
take 5 minutes for the first rpc errors to appear, now it takes 5 minutes
for GNOME splash screen to get out of the way - related ?).

        Possibly important - I use Quickswitch to switch network profiles.
This
basically changes hostname, IP address and gateway settings after the
bootup process ends. Have used it for a year nearly without any problems.
One problem that I had earlier was that I had an empty domainname when
using one of the network profiles which kept me from using a network
printer via lp but not using NFS volumes.

        Has the new kernel changed the hostname lookup mechanism somehow ?
If so,
how do I fix the soup I am in ?

        /var/log/messages shows that I have a lot of :

        modprobe: Can't locate module char-major-10-134 errors. Possibly
these
occured in the past as well, its just what I am noticing.

Just killed the Xserver after 10 minutes of waiting. I see a few :
(nautilus:2120) : Bonobo-WARNING **: Never got frame, control died -
abnormal exit errors.

Thanks,

MS