Debian Sarge boot problems on Mac 9600



I've got a Mac 9600 running Debian Sarge, but with an old 2.4.18 kernel. I
haven't been able to get any more recent kernel working for years; I've tried
compiling 2.4.27 and 2.6.8, amongst others.

The machine has an Adaptec 2940UW card in it running a RAID-1 for /home. The
old kernel has this as a module, but it won't autoload the module before
trying to mount /home, so I have to manually load the module and start the
RAID on boot-up. I've tried adding aic7xxx options to the boot params, but
nothing I've tried will load the module early enough.

I've been using make-kpkg to try to build a custom kernel with the driver in
it, but every kernel I build loads at the OF prompt, then the screen goes
blank and enters power-save. None of the kernels are booting the network.
I've tried adding boot params to set up the video card (it's the apparently
rare IMStt 8Mb with the TVP RAMDAC), to no avail. I've tried video=ofonly and
including the OpenFirmware console driver, but that blanks as well.

lspci reveals:
0000:00:0b.0 Host bridge: Apple Computer Inc. Bandit PowerPC host bridge (rev 03)
0000:00:0d.0 SCSI storage controller: Adaptec AHA-2940U/UW/D / AIC-7881U
0000:00:0f.0 Ethernet controller: 3Com Corporation 3c590 10BaseT [Vortex]
0000:00:10.0 ff00: Apple Computer Inc. Grand Central I/O (rev 02)
0000:01:0b.0 Host bridge: Apple Computer Inc. Bandit PowerPC host bridge (rev 03)
0000:01:0f.0 Display controller: Integrated Micro Solutions Inc. IMS9128 [Twin turbo 128] (rev 01)

I'm using quik as a bootloader. I've tried various boot params, including
adding the following for the 2.6.8 kernel:

append="video=imsttfb:vmode:14,cmode:8 console=tty6 aic7xxx=verbose md=0,/dev/sdc2,/dev/sdd2

The bootparams for the working 2.4.18 kernel are:

append="video=imsttfb:vmode:14,cmode:8 console=tty6"

Has anyone managed to get a recent kernel built and working on similar
hardware? If so, what was in your .config file?

a.
.