aRTs stopped working after upgrading to KDE3.2.3

From: Ilan Finci (ifinci_at_myrealbox.com)
Date: 06/23/04


Date: Wed, 23 Jun 2004 14:03:29 +0300

Hi,
I have a machine installed with SuSE 9.0. KDE 3.1.4 and everything was fine.

After upgrading to KDE 3.2.3 using the binary package for SuSE 9.0, I
now get an error message every time I login, or try to use an
application that uses aRTs for sound (most KDE apps).

Applications that uses sound directly, works fine (for example xmms
using the ALSA plugin for output).

The error message is:

Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = -1, can_write = 4096, errno = 4 (Interrupted system call)
This might be a sound hardware/driver specific problem (see aRts FAQ)

I've tried to build the source RPM from SuSE's site, but I can't get it
to compile.

Any idea?

Thanks,
Ilan



Relevant Pages

  • Re: KDE 3.3 ** New ** Packages Tonight - Heres the scoop
    ... > tonight at the Suse FTP site tonight, to fix problems in the Suse ... > I always assumed that the KDE section at the web site, ... No sound previews, unable to play sound files and unable to hear system ...
    (alt.os.linux.suse)
  • Re: [kde-linux] kdvi error with SuSE 9.3 and KDE 3.5
    ... > <start of error message> ... > However I can't find anything at SuSE for this. ... It looks like when I upgraded KDE 3.5, the KDEGRAPHICS3 package was still at ... > Richard Pace ...
    (KDE)
  • [kde-linux] kdvi error with SuSE 9.3 and KDE 3.5
    ... <start of error message> ... I found a bug report 117009 which concludes that this is a SuSE problem. ... However I can't find anything at SuSE for this. ... Has anyone with SuSE 9.3 and KDE 3.5 encountered this problem and resolved it? ...
    (KDE)
  • Re: No sound support for KDE
    ... I have a problem with the audio output of KDE 3.5.3 (the KDE version ... After the first launch of KDE I got a pop-up with the error message: ... "Sound server information message: ... To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx ...
    (Debian-User)
  • [SLE] What has sound and what does not in SuSE 9.2
    ... I have run several programs under SuSE 9.1 using KDE. ... The only program which does not provide sound so far is kdetv. ... When entering KDE there is no sound announcement but leaving KDE ... the chip at 0xc2. ...
    (SuSE)