[debian] problem with aptitude upgrade or dist-upgrade



# aptitude upgrade
*LOT_OF_PACKAGES_LISTED*
448 packages upgraded, 0 newly installed, 0 to remove and 437 not upgraded.
Need to get 0B/291MB of archives. After unpacking 117MB will be used.
Do you want to continue? [Y/n/?]
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 148016 files and directories currently installed.)
Preparing to replace libc6 2.5-9+b1 (using .../libc6_2.6.1-1+b1_i386.deb) ...
WARNING: POSIX threads library NPTL requires kernel version
2.6.8 or later. If you use a kernel 2.4, please upgrade it
before installing glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.6.1-1+b1_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.6.1-1+b1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

If i do as suggested:

# apt-get install -t etch linux-image-2.6
Reading package lists... Done
Building dependency tree... Done
Package linux-image-2.6 is a virtual package provided by:
linux-image-2.6.22-2-vserver-k7 2.6.22-4
linux-image-2.6.22-2-vserver-686 2.6.22-4
linux-image-2.6.22-2-k7 2.6.22-4
linux-image-2.6.22-2-amd64 2.6.22-4
linux-image-2.6.22-2-686-bigmem 2.6.22-4
linux-image-2.6.22-2-686 2.6.22-4
linux-image-2.6.22-2-486 2.6.22-4
You should explicitly select one to install.
E: Package linux-image-2.6 has no installation candidate

But:

a) i really don't want to change my kernel until it's strictly necessary, i
simply want to be up-to-date, and obviously it includes updating libc
b) why he thinks i have a 2.4 kernel? (i have a 2.6 kernel),
c) this error happened again once in Summer, i made so much trials that i dont
remember which one somehow solved, now i have the problem again, i wish to know
hot to do to fix definitely (and possibly forever :-) but i remember libc6 was
not updated,
d) searching for the error on google doesnt return useful infos.

Please help!

My sources.list:
deb http://security.debian.org/ testing/updates main
deb http://ftp.it.debian.org/debian/ testing main
deb-src http://ftp.it.debian.org/debian/ testing main

Kernel: 2.6.7-1-386

TIA for any advice/tip/hint.
--
Faciait li signeur!

Roy Batty
http://www.biolabnet.it/
.