Re: Newbie question: problems setting DISPLAY to X server

From: Tom Rauschenbach (tomsusenet_at_tomsdomain.org)
Date: 04/22/05


Date: Fri, 22 Apr 2005 10:01:26 -0400

On Tue, 19 Apr 2005 17:33:31 -0400, Bill Marcum wrote:

> On 19 Apr 2005 04:36:56 -0700, jose_luis_fdez_diaz_news@yahoo.es
> <jose_luis_fdez_diaz_news@yahoo.es> wrote:
>>
>> Hi,
>>
>> On my local machine (llamas.hi.inet: Linux FC3):
>>
>> [jdiaz@llamas ~]$ xhost +
>> access control disabled, clients can connect from any host
>> [jdiaz@llamas ~]$
>>
>> On the remote machine:
>>
>> opmxopge@sgbe2 : po_co_ordcorba.ss > export DISPLAY=llamas.hi.inet:0.0
>> opmxopge@sgbe2 : po_co_ordcorba.ss > xclock
>> Error: Can't open display: llamas.hi.inet:0.0
>> opmxopge@sgbe2 : po_co_ordcorba.ss > ping -s llamas.hi.inet
>> PING llamas.hi.inet: 56 data bytes
>> 64 bytes from llamas.hi.inet (10.95.27.186): icmp_seq=0. time=0. ms
>> 64 bytes from llamas.hi.inet (10.95.27.186): icmp_seq=1. time=1. ms
>> ^C
>> ----llamas.hi.inet PING Statistics----
>> 2 packets transmitted, 2 packets received, 0% packet loss
>> round-trip (ms) min/avg/max = 0/0/1
>> opmxopge@sgbe2 : po_co_ordcorba.ss >
>>
>> Any hint ?
>>
> I think this is a Frequently Asked Question. For "xhost +" to work, you
> need to be sure that your X server is started without the
> "-nolisten tcp" option. You don't want to use "xhost +" on a host
> connected to the Internet. Use ssh X forwarding instead.

Yeah, I found this one just yesterday. Look in
/etc/sysconfig/displaymanager for this. Now to find out how to do the ssh
X fowarding - hoping that's a FAQ too...