Sound, dual soundcards, second attempt (better I hope)

From: paul (paul_at_noret-pksings.net)
Date: 01/08/04


Date: Thu, 08 Jan 2004 04:19:26 GMT

I am attempting to setup two soundcards in Gentoo, kernel
2.4.22-gentoo-r2.

I believe that alsa is setup correctly, sound works wonderfully out of one
of the sound cards.

I first emerged alsa, then later in an attempt to solve this issue emerged
a newer kernel and re-compiled it and all the modules and switched to it.
I have also emerged alsa-tools.

The following is the output or lsmod.

deejay root # lsmod
Module Size Used by Tainted: PF
snd-pcm-oss 34372 0 (autoclean)
smbfs 31696 1 (autoclean)
driverloader 122376 1
snd-mixer-oss 10864 1 [snd-pcm-oss]
snd-emu10k1 57332 1 (autoclean)
snd-pcm 53984 0 (autoclean) [snd-pcm-oss snd-emu10k1]
snd-hwdep 4256 0 (autoclean) [snd-emu10k1]
snd-rawmidi 12160 0 (autoclean) [snd-emu10k1]
snd-util-mem 1184 0 (autoclean) [snd-emu10k1]
snd-page-alloc 5428 0 (autoclean) [snd-emu10k1 snd-pcm]
snd-ac97-codec 35512 0 (autoclean) [snd-emu10k1]
snd-timer 13156 0 [snd-pcm]
snd-seq-device 3568 0 [snd-emu10k1 snd-rawmidi]
snd 28324 1 [snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-pcm snd-hwdep snd-rawmidi snd-util-mem snd-ac97-codec snd-timer snd-seq-device]
soundcore 3364 12 [snd]
nls_iso8859-1 2780 1 (autoclean)
nls_cp437 4316 1 (autoclean)
vfat 9100 1 (autoclean)
fat 29272 0 (autoclean) [vfat]
serial 50564 0 (unused)
isa-pnp 27204 0 [serial]
loop 8124 0 (unused)
ide-tape 40080 0 (autoclean)
st 27052 0 (autoclean) (unused)
usb-storage 56348 0 (unused)
hid 13332 0 (unused)
usb-ohci 17312 0 (unused)
uhci 22752 0 (unused)
ehci-hcd 14944 0 (unused)
usbcore 55264 1 [usb-storage hid usb-ohci uhci ehci-hcd]
initio 17396 0 (unused)
ncr53c8xx 50996 3

The following is /proc/asound
lrwxrwxrwx 1 root root 5 Jan 8 08:15 Live -> card0
lrwxrwxrwx 1 root root 5 Jan 8 08:15 Live_1 -> card1
dr-xr-xr-x 7 root root 0 Jan 8 08:15 card0
dr-xr-xr-x 7 root root 0 Jan 8 08:15 card1
-r--r--r-- 1 root root 0 Jan 8 08:15 cards
-r--r--r-- 1 root root 0 Jan 8 08:15 devices
-r--r--r-- 1 root root 0 Jan 8 08:15 hwdep
-r--r--r-- 1 root root 0 Jan 8 08:15 modules
dr-xr-xr-x 2 root root 0 Jan 8 08:15 oss
-r--r--r-- 1 root root 0 Jan 8 08:15 pcm
dr-xr-xr-x 2 root root 0 Jan 8 08:15 seq
-r--r--r-- 1 root root 0 Jan 8 08:15 timers
-r--r--r-- 1 root root 0 Jan 8 08:15 version

The above seen devices file contains the following.
deejay asound # cat devices
  0: [0- 0]: ctl
  4: [0- 0]: hardware dependent
  8: [0- 0]: raw midi
 19: [0- 3]: digital audio playback
 26: [0- 2]: digital audio capture
 25: [0- 1]: digital audio capture
 16: [0- 0]: digital audio playback
 24: [0- 0]: digital audio capture
 33: : timer
 32: [1- 0]: ctl
 36: [1- 0]: hardware dependent
 40: [1- 0]: raw midi
 51: [1- 3]: digital audio playback
 58: [1- 2]: digital audio capture
 57: [1- 1]: digital audio capture

deejay asound # cat modules
0 snd-emu10k1
1 snd-emu10k1

 48: [1- 0]: digital audio playback
 56: [1- 0]: digital audio capture

deejay root # cat /root/dmesg.txt
Linux version 2.4.22-gentoo-r2 (root@deejay.pksings.com) (gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r1, propolice)) #2 Sun Dec 28 10:53:49 PST 2003
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000ec000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
 BIOS-e820: 000000001fff0000 - 000000001fff8000 (ACPI data)
 BIOS-e820: 000000001fff8000 - 0000000020000000 (ACPI NVS)
 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000ffee0000 - 00000000fff00000 (reserved)
 BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
511MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 131056
zone(0): 4096 pages.
zone(1): 126960 pages.
zone(2): 0 pages.
ACPI: RSDP (v000 AMI ) @ 0x000fa2c0
ACPI: RSDT (v001 AMIINT SiS735XX 0x00001000 MSFT 0x0100000b) @ 0x1fff0000
ACPI: FADT (v001 AMIINT SiS735XX 0x00001000 MSFT 0x0100000b) @ 0x1fff0030
ACPI: DSDT (v001 SiS 735 0x00000100 MSFT 0x0100000d) @ 0x00000000
Kernel command line: auto BOOT_IMAGE=gentoo root=803
Initializing CPU#0
Detected 1792.632 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 3547.13 BogoMIPS
Memory: 513852k/524224k available (1924k kernel code, 9984k reserved, 291k data, 116k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: CLK_CTL MSR was 6003d22f. Reprogramming to 2003d22f
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After generic, caps: 0383f9ff c1cbf9ff 00000000 00000000
CPU: Common caps: 0383f9ff c1cbf9ff 00000000 00000000
CPU: AMD Athlon(tm) XP 2200+ stepping 01
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20031002
PCI: PCI BIOS revision 2.10 entry at 0xfdb01, last bus=1
PCI: Using configuration type 1
ACPI: IRQ9 SCI: Edge set to Level Trigger.
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: System [ACPI] (supports S0 S1 S4 S5)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [URP2] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
ACPI: PCI Interrupt Link [LNKA] (IRQs *11)
ACPI: PCI Interrupt Link [LNKB] (IRQs *11)
ACPI: PCI Interrupt Link [LNKC] (IRQs *3 4 5 7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 7 *10 12 14 15)
PCI: Probing PCI hardware
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 5
ACPI: PCI Interrupt Link [LNKH] enabled at IRQ 10
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 11
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 3
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even 'acpi=off'
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Journalled Block Device driver loaded
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
SGI XFS snapshot 2.4.22-2003-09-03_04:09_UTC with realtime, no debug enabled
SGI XFS Quota Management subsystem
pty: 256 Unix98 ptys configured
Real Time Clock Driver v1.10e
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
Equalizer1996: $Revision: 1.2.1 $ $Date: 1996/09/22 13:52:00 $ Simon Janes (simon@ncm.com)
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller at PCI slot 00:02.5
SIS5513: chipset revision 208
SIS5513: not 100% native mode: will probe irqs later
SIS5513: SiS735 ATA 100 (2nd gen) controller
    ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdc:DMA, hdd:DMA
hda: WDC WD1200JB-00DUA3, ATA DISK drive
blk: queue c016f320, I/O limit 4095Mb (mask 0xffffffff)
hdc: LTN526S, ATAPI CD/DVD-ROM drive
hdd: LITE-ON LTR-48246S, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=14593/255/63, UDMA(100)
hdc: attached ide-cdrom driver.
hdc: ATAPI 52X CD-ROM drive, 120kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdd: attached ide-cdrom driver.
hdd: ATAPI 48X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 < p5 p6 p7 >
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
mice: PS/2 mouse device common for all mice
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
IPv6 v0.8 for NET4.0
IPv6 over IPv4 tunneling driver
Measuring network checksumming speed
   basic : 480.000 MB/sec
   simple : 456.000 MB/sec
   3Dnow! : 696.000 MB/sec
   AMD-MMX : 696.000 MB/sec
   SSE1+ : 696.000 MB/sec
csum: using csum function: 3Dnow!
   basic : 248.000 MB/sec
   simple : 232.000 MB/sec
   AMD-MMX : 432.000 MB/sec
   SSE1+ : 432.000 MB/sec
   SSE1 : 424.000 MB/sec
csum: using csum_copy function: AMD-MMX
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 1435k freed
VFS: Mounted root (ext2 filesystem).
ncr53c8xx: at PCI bus 0, device 11, function 0
ncr53c8xx: 53c875 detected with Symbios NVRAM
ncr53c875-0: rev 0x26 on pci bus 0 device 11 function 0 irq 11
ncr53c875-0: Symbios format NVRAM, ID 7, Fast-20, NO Parity
ncr53c875-0: on-chip RAM at 0xcfffa000
ncr53c875-0: restart (scsi reset).
ncr53c875-0: Downloading SCSI SCRIPTS.
scsi0 : ncr53c8xx-3.4.3b-20010512
  Vendor: SEAGATE Model: SX118273LC Rev: 6367
  Type: Direct-Access ANSI SCSI revision: 02
  Vendor: SEAGATE Model: SX118273LC Rev: 6367
  Type: Direct-Access ANSI SCSI revision: 02
ncr53c875-0-<0,0>: tagged command queue depth set to 4
ncr53c875-0-<1,0>: tagged command queue depth set to 4
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi disk sdb at scsi0, channel 0, id 1, lun 0
ncr53c875-0-<0,*>: FAST-20 SCSI 20.0 MB/s (50 ns, offset 15)
SCSI device sda: 35566480 512-byte hdwr sectors (18210 MB)
 /dev/scsi/host0/bus0/target0/lun0: p1 p2 p3
ncr53c875-0-<1,*>: FAST-20 WIDE SCSI 40.0 MB/s (50 ns, offset 15)
SCSI device sdb: 35566480 512-byte hdwr sectors (18210 MB)
 /dev/scsi/host0/bus0/target1/lun0: p1 p2
NCR53c406a: no available ports found
i91u: PCI Base=0xD800, IRQ=11, BIOS=0xFF000, SCSI ID=7
i91u: Reset SCSI Bus ...
scsi1 : Initio INI-9X00U/UW SCSI device driver; Revision: 1.03g
  Vendor: Model: Rev:
  Type: Scanner ANSI SCSI revision: 03
  Vendor: Model: Rev:
  Type: Scanner ANSI SCSI revision: 03
  Vendor: Model: Rev:
  Type: Scanner ANSI SCSI revision: 03
Attached scsi generic sg2 at scsi1, channel 0, id 4, lun 0, type 6
Attached scsi generic sg3 at scsi1, channel 0, id 4, lun 1, type 6
Attached scsi generic sg4 at scsi1, channel 0, id 4, lun 2, type 6
aec671x_detect:
scsi: <fdomain> Detection failed (no card)
GDT: Storage RAID Controller Driver. Version: 2.05
GDT: Found 0 PCI Storage RAID Controllers
megaraid: v1.18f (Release Date: Tue Dec 10 09:54:39 EST 2002)
megaraid: no BIOS enabled.
DC390: 0 adapters found
Failed initialization of WD-7000 SCSI card!
3ware Storage Controller device driver for Linux v1.02.00.036.
3w-xxxx: No cards found.
NCR53c406a: no available ports found
Red Hat/Adaptec aacraid driver (1.1.2 Dec 28 2003 10:31:57)
sym.0.11.0: IO region 0xd400[0..127] is in use
Loading Adaptec I2O RAID: Version 2.4 Build 5
Detecting Adaptec I2O RAID controllers...
sim710: No NCR53C710 adapter found.
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
ehci_hcd 00:13.2: VIA Technologies, Inc. USB 2.0
ehci_hcd 00:13.2: irq 3, pci mem e0837e00
usb.c: new USB bus registered, assigned bus number 1
PCI: 00:13.2 PCI cache line size set incorrectly (32 bytes) by BIOS/FW.
PCI: 00:13.2 cache line size too large - expecting 16.
ehci_hcd 00:13.2: USB 2.0 enabled, EHCI 0.95, driver 2003-Jun-19/2.4
hub.c: USB hub found
hub.c: 4 ports detected
uhci.c: USB Universal Host Controller Interface driver v1.1
uhci.c: USB UHCI at I/O 0xc400, IRQ 11
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
uhci.c: USB UHCI at I/O 0xc000, IRQ 11
usb.c: new USB bus registered, assigned bus number 3
hub.c: USB hub found
hub.c: 2 ports detected
usb-ohci.c: USB OHCI at membase 0xe0846000, IRQ 10
usb-ohci.c: usb-00:02.3, Silicon Integrated Systems [SiS] USB 1.0 Controller (#2)
usb.c: new USB bus registered, assigned bus number 4
hub.c: USB hub found
hub.c: 3 ports detected
usb-ohci.c: USB OHCI at membase 0xe0848000, IRQ 5
usb-ohci.c: usb-00:02.2, Silicon Integrated Systems [SiS] USB 1.0 Controller
usb.c: new USB bus registered, assigned bus number 5
hub.c: USB hub found
hub.c: 3 ports detected
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
reiserfs: found format "3.6" with standard journal
reiserfs: checking transaction log (device sd(8,3)) ...
for (sd(8,3))
sd(8,3):Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Trying to move old root to /initrd ... failed
Unmounting old root
Trying to free ramdisk memory ... okay
Freeing unused kernel memory: 116k freed
Adding Swap: 500728k swap-space (priority -1)
loop: loaded (max 8 devices)
sym.0.11.0: IO region 0xd400[0..127] is in use
sis900.c: v1.08.06 9/24/2002
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP enabled
reiserfs: found format "3.6" with standard journal
reiserfs: checking transaction log (device sd(8,18)) ...
for (sd(8,18))
sd(8,18):Using r5 hash to sort names
reiserfs: found format "3.6" with standard journal
reiserfs: checking transaction log (device ide0(3,6)) ...
for (ide0(3,6))
ide0(3,6):Using r5 hash to sort names
kjournald starting. Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS 2.4-0.9.19+htree+orlov, 19 August 2002 on ide0(3,7), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
devfs_register(unknown): could not append to parent, err: -17
devfs_register(unknown): could not append to parent, err: -17
devfs_register(unknown): could not append to parent, err: -17
devfs_register(unknown): could not append to parent, err: -17
devfs_register(unknown): could not append to parent, err: -17
devfs_register(unknown): could not append to parent, err: -17
devfs_register(unknown): could not append to parent, err: -17
00:11.0: cache line size not set; forcing 4
eth0: New link status: Disconnected (0002)
eth0: AES, TKIP, WEP104, WEP40 supported
eth0: at 00:11.0 (MAC address 00:90:96:67:3F:08) ready
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
eth0: New link status: Connected (0001)
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
eth0: no IPv6 routers present
inserting floppy driver for 2.4.22-gentoo-r2
floppy0: no floppy controllers found
Creative EMU10K1 PCI Audio Driver, version 0.20a, 04:54:52 Dec 29 2003
devfs_register(unknown): could not append to parent, err: -17
devfs_register(unknown): could not append to parent, err: -17
devfs_register(unknown): could not append to parent, err: -17
deejay root #

I am under the belief that I should have /dev/dsp and /dev/dsp1 and I do
not
deejay oss # ls -l /dev/dsp*
lr-xr-xr-x 1 root root 9 Jan 7 11:01 /dev/dsp -> sound/dsp
deejay oss #

deejay etc # cat modules.conf
### This file is automatically generated by modules-update
#
# Please do not edit this file directly. If you want to change or add
# anything please take a look at the files in /etc/modules.d and read
# the manpage for modules-update.
#
### modules-update: start processing /etc/modules.d/aliases
# Aliases to tell insmod/modprobe which modules to use
 
# Uncomment the network protocols you don't want loaded:
# alias net-pf-1 off # Unix
# alias net-pf-2 off # IPv4
# alias net-pf-3 off # Amateur Radio AX.25
# alias net-pf-4 off # IPX
# alias net-pf-5 off # DDP / appletalk
# alias net-pf-6 off # Amateur Radio NET/ROM
# alias net-pf-9 off # X.25
# alias net-pf-10 off # IPv6
# alias net-pf-11 off # ROSE / Amateur Radio X.25 PLP
# alias net-pf-19 off # Acorn Econet
 
alias char-major-10-175 agpgart
alias char-major-10-200 tun
alias char-major-81 bttv
alias char-major-108 ppp_generic
alias /dev/ppp ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate
 
# Crypto modules (see http://www.kerneli.org/)
alias loop-xfer-gen-0 loop_gen
alias loop-xfer-3 loop_fish2
alias loop-xfer-gen-10 loop_gen
alias cipher-2 des
alias cipher-3 fish2
alias cipher-4 blowfish
alias cipher-6 idea
alias cipher-7 serp6f
alias cipher-8 mars6
alias cipher-11 rc62
alias cipher-15 dfc2
alias cipher-16 rijndael
alias cipher-17 rc5
 
# Support for i2c and lm_sensors
alias char-major-89 i2c-dev
 
# Old nvidia support ...
alias char-major-195 NVdriver
alias /dev/nvidiactl char-major-195
 
### modules-update: end processing /etc/modules.d/aliases
 
### modules-update: start processing /etc/modules.d/alsa
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf-rc,v 1.1 2002/12/21 06:31:52 agenkin Exp $
 
# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore
 
##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
## ALSA portion
alias snd-card-0 snd-emu10k1
alias snd-card-1 snd-emu10k1
## OSS/Free portion
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1
##
 
# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
# OSS/Free portion - card #2
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss
 
alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss
 
# Set this to the correct number of cards.
options snd cards_limit=2
 
### modules-update: end processing /etc/modules.d/alsa
 
### modules-update: start processing /etc/modules.d/driverloader
 
### modules-update: end processing /etc/modules.d/driverloader
 
### modules-update: start processing /etc/modules.d/emu10k1
post-install emu10k1 /usr/bin/emu10k1-script restore
pre-remove emu10k1 /usr/bin/emu10k1-script save
 
### modules-update: end processing /etc/modules.d/emu10k1
 
### modules-update: start processing /etc/modules.d/i386
alias parport_lowlevel parport_pc
alias char-major-10-144 nvram
alias binfmt-0064 binfmt_aout
alias char-major-10-135 rtc
 
### modules-update: end processing /etc/modules.d/i386

I have run the "update-modules" command.

I hope this is enough information that someone can help me figure out
what's wrong.

Thank you

PK



Relevant Pages