Re: Error while installing firefox

From: Conny (NOSPAMuncurbed_at_swipnet.se)
Date: 12/16/04


Date: Thu, 16 Dec 2004 22:16:07 GMT


"Mike Rappe" <mrappe@houston.rr.com> skrev i meddelandet
news:41C1E18B.8090308@houston.rr.com...
>I am trying to install Firefox on my Linux PC.I have
>
> Red Hat Linux release 8.0 (Psyche)
>
> Kernel 2.4.18-14bigmem on an i686
>
> Installed with 128 M Ram and pleny of disk space.
>
> These are the listed requirements for Firefox
>
> I downloaded the Firefox installer for Linux. When running the installer I
> got an error message while the installer reached this point: Extracting
> libplc4.so...
> Then I got an alert box that said this :
> Fatal Error [-618]: Couldn't open xpistub library
> The terminal session from which I launched the installer had this error:
>
> [root@localhost firefox-installer]# bash firefox-installer
>
> ** (firefox-installer-bin:4208): WARNING **: Invalid UTF8 string passed to
> pango
> _layout_set_text()
>
> ** (firefox-installer-bin:4208): WARNING **: Invalid UTF8 string passed to
> pango
> _layout_set_text()
>
> ** (firefox-installer-bin:4208): WARNING **: Invalid UTF8 string passed to
> pango
> _layout_set_text()
>
> ** (firefox-installer-bin:4208): WARNING **: Invalid UTF8 string passed to
> pango
> _layout_set_text()
> DLError: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found
> (required by
> [root@localhost firefox-installer]# bash firefox-installer
> DLError: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found
> (required by ./libnspr4.so)^[[2~
>
> Can anyone point me to what I need to do. I am not sure where GLIBC_2.3.2
> should be at or what version that I have or what it would take to update
> if needed.
>
> Thank You,
>
> m rappe@houston.rr.com
> (remove the space between m and r)
>
>
>

Install glibc?!
get the glibc package with 'swaret' or 'slapt-get' or download it and
install it manually with 'installpkg'