Help me please :: about oracle / php



Would you like to help me to solve this problem.
1. can u see problem/fact below and can u suggest me sir ?


2. can u tell me about error
2.1 libclntsh.so.10.1
2.2 libnnz10.so
2.3 libocci.so.10.1
2.4 libociei.so
2.5 libocijdbc10.so
Can u tell me what i need to install to solve this message ?

3. Can u tell me about the rpm install / not compile to install ?
:::: because i not clever about install some package with complie (
make , make install ) sir.


================================
Help me please about Oracle client. on php
================================
I try this site .
( http://freshrpms.net/docs/oracle/ )

And get result.
Can u tell me how-to solve ?.

[root@mammos oracle]# ls -l
total 36588
-rw-r--r-- 1 root root 66764 Aug 25 16:35
libsqlora8-2.3.2-5.2.el4.i386.rpm
-rw-r--r-- 1 root root 8916 Aug 25 16:35
libsqlora8-debuginfo-2.3.2-5.2.el4.i386.rpm
-rw-r--r-- 1 root root 776425 Aug 25 16:35
libsqlora8-devel-2.3.2-5.2.el4.i386.rpm
-rw-r--r-- 1 root root 33449686 Oct 17 15:56
oracle-instantclient-basic-10.2.0.1-1.i386.rpm
-rw-r--r-- 1 root root 288381 Oct 26 21:31
oracle-instantclient-devel-10.2.0.1-1.i386.rpm
-rw-r--r-- 1 root root 1481178 Oct 17 15:56
oracle-instantclient-jdbc-10.2.0.1-1.i386.rpm
-rw-r--r-- 1 root root 738536 Oct 17 15:56
oracle-instantclient-sqlplus-10.2.0.1-1.i386.rpm
-rw-r--r-- 1 root root 172829 Apr 11 2005
perl-DBD-Oracle-1.16-2.2.el4.i386.rpm
-rw-r--r-- 1 root root 112422 Apr 11 2005
perl-DBD-Oracle-debuginfo-1.16-2.2.el4.i386.rpm
-rw-r--r-- 1 root root 8220 Nov 3 00:05
php-4.3.10-oci8instantclient.patch
-rw-r--r-- 1 root root 6019 Nov 3 00:05 php-modules.spec
-rw-r--r-- 1 root root 31422 Apr 8 2005
php-oci8-4.3.9-2.2.el4.i386.rpm
-rw-r--r-- 1 root root 79951 Jun 23 2005
squale-0.1.5-1.2.el4.i386.rpm
-rw-r--r-- 1 root root 130631 Jun 23 2005
squale-debuginfo-0.1.5-1.2.el4.i386.rpm
-rw-r--r-- 1 root root 8128 Jun 23 2005
squale-devel-0.1.5-1.2.el4.i386.rpm
[root@mammos oracle]# rpm -Uvh *
php-4.3.10-oci8instantclient.patch: not an rpm package (or package
manifest):
[root@mammos oracle]# rm -rf php-4.3.10-oci8instantclient.patch
[root@mammos oracle]# rpm -Uvh *
php-modules.spec: not an rpm package (or package manifest):
[root@mammos oracle]# rm -rf php-modules.spec
[root@mammos oracle]# rpm -Uvh *
error: Failed dependencies:
libclntsh.so.10.1 is needed by libsqlora8-2.3.2-5.2.el4.i386
libclntsh.so.10.1 is needed by
perl-DBD-Oracle-1.16-2.2.el4.i386
libnnz10.so is needed by perl-DBD-Oracle-1.16-2.2.el4.i386
libocci.so.10.1 is needed by perl-DBD-Oracle-1.16-2.2.el4.i386
libociei.so is needed by perl-DBD-Oracle-1.16-2.2.el4.i386
libocijdbc10.so is needed by perl-DBD-Oracle-1.16-2.2.el4.i386
libclntsh.so.10.1 is needed by php-oci8-4.3.9-2.2.el4.i386
libclntsh.so.10.1 is needed by squale-0.1.5-1.2.el4.i386
[root@mammos oracle]#



Thank you very much for advance
Pratchaya

PS. I use RHEL4ES with i386 series.

.



Relevant Pages

  • Re: FPGA editor in Fedora 11 x86_64
    ... install the rpm package from www.motifzone.net. ... libkernel50.so to use relocation as a workaround, ... you can change the file context to textrel_shlib_t. ...
    (comp.arch.fpga)
  • Re: [opensuse] Firefox "open with Package Installer" failure
    ... Il 31/12/2012 09:32, Carl Hartung ha scritto: ... trying to install a new version of VirtualBox by clicking ... In the case mentioned it is a generic RPM package. ...
    (SuSE)
  • report load failed
    ... software in my system that time it will working, i will try to install some ... thing is server doesnot have .net software only my machine installed .net ... is possible with report its not working sir ...
    (microsoft.public.dotnet.languages.vb)
  • Re: How do I use IM to talk to MS IM users?
    ... >May I ask you that how can I use IM to talk to MS IM users on RH9? ... the command "up2date gaim" if you have that configured, ... automatically download and install the program, ... Get the RPM package for the latest version (one was released just ...
    (RedHat)
  • Re: [SLE] update evolution
    ... either install from source or use red carpet to get an updated ... SUSE is an rpm package based distribution so you should primarily be looking ... You can add both the KDE and GNOME update directories as installation sources ...
    (SuSE)