rpm doesn't recognize installed version of python



Hi Folks,

I'm trying to install bittorrent (http://download.bittorrent.com/dl/
BitTorrent-5.0.3-1-Python2.4.noarch.rpm) on my ancient redhat 7.3
system. It requires a recent version of python, so I installed python
2.5.2 from source (http://www.python.org/ftp/python/2.5.2/
Python-2.5.2.tar.bz2). I ran ./configure, make and make install.

Now, however, when I run "rpm -ivh BitTorrent-5.0.3-1-
Python2.4.noarch.rpm", I get:

error: failed dependencies:
/usr/bin/python2.4 is needed by BitTorrent-5.0.3-1
python >= 2.3 is needed by BitTorrent-5.0.3-1
python(abi) = 2.4 is needed by BitTorrent-5.0.3-1
python-crypto >= 2.0 is needed by BitTorrent-5.0.3-1
python-psyco is needed by BitTorrent-5.0.3-1
python-twisted >= 2.0 is needed by BitTorrent-5.0.3-1
python-zopeinterface is needed by BitTorrent-5.0.3-1
wxPython >= 2.6 is needed by BitTorrent-5.0.3-1

Is rpm not seeing my python 2.5? I ran "ln -s /usr/local/bin/python /
usr/bin/python", but that didn't help. Any suggestions are very
welcome. Thanks y'all!

allie
.