Re: rpm doesn't recognize installed version of python



Allie wrote:
Hi Folks,

I'm trying to install bittorrent (http://download.bittorrent.com/dl/
BitTorrent-5.0.3-1-Python2.4.noarch.rpm) on my ancient redhat 7.3
system. It requires a recent version of python, so I installed python
2.5.2 from source (http://www.python.org/ftp/python/2.5.2/
Python-2.5.2.tar.bz2). I ran ./configure, make and make install.

Now, however, when I run "rpm -ivh BitTorrent-5.0.3-1-
Python2.4.noarch.rpm", I get:

error: failed dependencies:
/usr/bin/python2.4 is needed by BitTorrent-5.0.3-1
python >= 2.3 is needed by BitTorrent-5.0.3-1
python(abi) = 2.4 is needed by BitTorrent-5.0.3-1
python-crypto >= 2.0 is needed by BitTorrent-5.0.3-1
python-psyco is needed by BitTorrent-5.0.3-1
python-twisted >= 2.0 is needed by BitTorrent-5.0.3-1
python-zopeinterface is needed by BitTorrent-5.0.3-1
wxPython >= 2.6 is needed by BitTorrent-5.0.3-1

Is rpm not seeing my python 2.5? I ran "ln -s /usr/local/bin/python /
usr/bin/python", but that didn't help. Any suggestions are very
welcome. Thanks y'all!

I have no idea what the problem is as I used to run that without a problem. But quick solution is to use ktorrent which I use today. It is an incredibly mature implementation -- admitting I have not tried them all.

The slow solution is to use yum to install those dependencies but maybe first looking for a bittorrent.rpm file.

--
Is it legitimate to ask why the only country that was friendly to apartheid
South Africa was Israel or is that an antisemitic question?
-- The Iron Webmaster, 3978
http://www.haaretz.com What is Israel really like? http://www.jpost.com a7
.